NumberTriangles triangles

Description

Consider the number triangle shown below. Write a program thatcalculates the highest sum of numbers that can be passed on a routethat starts at the top and ends somewhere on the base. Each stepcan go either diagonally down to the left or diagonally down to theright.

          7        3   8      8   1   0    2   7   4   4  4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5produces the highest sum: 30.

Input

The first line contains R (1 <= R<= 1000), the number of rows. Each subsequent linecontains the integers for that particular row of the triangle. Allthe supplied integers are non-negative and no larger than 100.

Output

A single line containing the largest sum using the traversalspecified.

Sample Input

573 88 1 02 7 4 44 5 2 6 5

Sample Output

30

#include<iostream>
NumberTriangles triangles
using namespace std;
int main()
{
intn,i,j;
cin>>n;
int **a=newint *[n];
for(i=0;i<n;i++)
a[i]=new int[i+1];
for(i=0;i<n;i++)
for(j=0;j<=i;j++)
cin>>a[i][j];
for(i=n-2;i>=0;i--)
for(j=0;j<=i;j++)//从下往上依次遍历!
a[i][j]+=(a[i+1][j]>a[i+1][j+1])?a[i+1][j]:a[i+1][j+1];
cout<<a[0][0]<<endl;
}

  

爱华网本文地址 » http://www.413yy.cn/a/25101016/288628.html

更多阅读

我不管 华晨宇 歌词 华晨宇《我管你》中文歌词

&#160;  这首充满叛逆痞气的《我管你》是华晨宇一气呵成的原创。当今天的摇滚变得很娱乐、很逃避,听众与歌手共同走入五光十色的蜜缸时,华晨宇决心打造自己的新摇滚时代&#8212;&#8212;拒绝速食糖水的气质,大步越过与形而上学的模仿秀

潜在竞争者的威胁 常用电器会给健康带来哪些潜在的威胁?

  现代办公室必备的办公设备无非就是电脑、复印机、打印机等,这些设备给了我们工作极大便利的同时,也可能给我们的健康带来潜在的威胁。  电器设备对健康最大的威胁就是产生臭氧。臭氧是有强烈刺激性气味的气体,除了可能致癌外,臭

声明:《NumberTriangles triangles》为网友夏日的綠色分享!如侵犯到您的合法权益请联系我们删除