跨域mplsvpnoptionA配置 cisco mpls vpn 配置

Option A是背靠背的MPLS VPN,ASBR将与另一AS互联的接口认为是CE接口,配置VRF。

ASBR之间配置EBGP邻居,并在Addressfamily ipv4中设置EBGP邻居。

PE1:

ip vrf vpna
rd 100:1
route-target export 100:1
route-target import 100:1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding vpna
ip address 100.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.1.1.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf vpna
redistribute connected
no synchronization
exit-address-family

ASBR1:

ip vrf vpna
rd 100:1
route-target export 100:1
route-target import 100:1

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
ip vrf forwarding vpna
ip address 23.1.1.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.1.1.0 0.0.0.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 23.1.1.2 remote-as 200
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf vpna
neighbor 23.1.1.2 remote-as 200
neighbor 23.1.1.2 activate
no synchronization
exit-address-family

ASBR2:

ip vrf vpna
rd 100:1
route-target export 100:1
route-target import 100:1

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding vpna
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 34.1.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 34.1.1.0 0.0.0.255 area 0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 200
neighbor 4.4.4.4 update-source Loopback0
neighbor 23.1.1.1 remote-as 100
no auto-summary
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf vpna
neighbor 23.1.1.1 remote-as 100
neighbor 23.1.1.1 activate
no synchronization
exit-address-family

PE2:

ip vrf vpna
rd 100:1
route-target export 100:1
route-target import 100:1

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip vrf forwarding vpna
ip address 200.1.1.1 255.255.255.0
!
跨域mplsvpnoptionA配置 cisco mpls vpn 配置
interface FastEthernet0/0
ip address 34.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 34.1.1.0 0.0.0.255 area 0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 200
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf vpna
redistribute connected
no synchronization
exit-address-family

查看vrf路由表:

PE1:

100.0.0.0/24 is subnetted, 1 subnets
C100.1.1.0 is directly connected, Loopback1
B200.1.1.0/24 [200/0] via 2.2.2.2, 00:18:54

ASBR1:


100.0.0.0/24 is subnetted, 1 subnets
B100.1.1.0 [200/0] via 1.1.1.1, 02:34:21
B200.1.1.0/24 [20/0] via 23.1.1.2, 00:19:44
23.0.0.0/24 is subnetted, 1 subnets
C23.1.1.0 is directly connected, FastEthernet1/0

  

爱华网本文地址 » http://www.413yy.cn/a/25101011/61676.html

更多阅读

园林植物配置心得 园林植物配置

园林植物按植物生态习性和园林布局要求,合理配置园林中各种植物(乔木、灌木、花卉、草皮和地被植物等),以发挥它们的园林功能和观赏特性。园林植物配置是园林规划设计的重要环节。  园林植物的配置包括两个方面:一方面是各种植物相

Quartz quartz.properties配置文件 java quartz 配置文件

[size=medium]3.声明式部署一个Job前面我们讨论过,尽可能的用声明式处理软件配置,其次才才虑编程式。再来看代码3.6,如果我们要在Job启动之后改变它的执行时间和频度,必须去修改源代码重新编译。这种方式只适用于小的例子程序,但是对于一

pptp VPN原理与安装配置 tomato pptp vpn 配置

在介绍pptp VPN之前我们先来了解一下隧道技术。隧道技术的基本过程是在源局域网与公网的接口处将数据(可以是ISO 七层模型中的数据链路层或网络层数据)作为负载封装在一种可以在公网上传输的数据格式中,在目的局域网与公网的接口处将

声明:《跨域mplsvpnoptionA配置 cisco mpls vpn 配置》为网友隐匿在梦境分享!如侵犯到您的合法权益请联系我们删除